Display Issue - Monad USDC

Incident Report for Coinbase Exchange

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 16:05 PST

Update

We are continuing to investigate the issue affecting the display of balances for USDC on Monad on coinbase.com and the mobile app.

While we work on the display issue, we are aware that some users may experience delayed Sends and Receives on the Monad network.

Rest assured your funds are safe. Buys, Sells, and Fiat withdrawals/deposits remain unaffected. We are working on this issue and will provide updates as the situation changes.
Posted Nov 26, 2025 - 14:41 PST

Investigating

We’re currently investigating an issue affecting the display of balances for USDC on Monad on coinbase.com and the mobile app. This is purely a display issue, and your funds are safe. We’re actively working to identify the root cause and resolve it as soon as possible.
Posted Nov 26, 2025 - 10:07 PST