Our ZETACHAIN-USD trading pair will now enter limit-only mode on @CoinbaseExch and Advanced Trade. Limit orders can be placed and canceled, and matches may occur. Market orders cannot be submitted.
Posted Sep 23, 2024 - 09:17 PDT
Update
Our ZETACHAIN-USD trading pair will now enter auction mode. Customers can post limit orders and view the resulting indicative open price. The books will be in auction mode for a minimum of 10 minutes during which no matches will occur. Upon completion of the auction, crossed orders will be matched at the opening price.
Posted Sep 23, 2024 - 08:59 PDT
Update
Update: Trading is now expected to begin on 23 September 2024, if liquidity conditions are met. Follow along the launch of trading and updates at @CoinbaseExch.
Posted Sep 20, 2024 - 13:14 PDT
Update
Update: Trading is now expected to begin on September 20, if liquidity conditions are met. Follow along the launch of trading and updates at @CoinbaseExch.
Posted Sep 19, 2024 - 18:07 PDT
Monitoring
Coinbase will add support for Zetachain (ZETACHAIN) on the Zetachain network. Do not send this asset over other networks or your funds may be lost. Transfers for this asset are available on @Coinbase & @CoinbaseExch in the regions where trading is supported. Trading will begin on or after 9AM PT on September 19, 2024, if liquidity conditions are met. Once sufficient supply of this asset is established, trading on our ZETACHAIN-USD trading pair will launch in phases. Support for ZETACHAIN may be restricted in some supported jurisdictions.