We are currently investigating an issue causing delays in BTC withdrawals. Deposits are unaffected.
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Apr 10, 2021 - 04:45 PDT
Investigating
We are currently investigating this issue.
Posted Apr 10, 2021 - 04:23 PDT
This incident affected: Transfers (Coinbase Bitcoin).