BLOCKLORDS (LRDS) is now live on http://coinbase.com & in the Coinbase iOS & Android apps with the Experimental label. Coinbase customers can log in to buy, sell, convert, send, receive or store these assets.
Posted Jul 24, 2024 - 10:25 PDT
Update
Our LRDS-USD trading pair will now enter limit-only mode on @CoinbaseExch and Advanced Trade. Limit orders can be placed and canceled, and matches may occur. Market orders cannot be submitted.
Posted Jul 24, 2024 - 10:18 PDT
Update
Our LRDS-USD trading pair will now enter auction mode. Customers can post limit orders and view the resulting indicative open price. The books will be in auction mode for a minimum of 10 minutes during which no matches will occur.
Posted Jul 24, 2024 - 10:06 PDT
Update
The Ethereum network (ERC-20 token) contract address for BLOCKLORDS (LRDS) is 0xd0a6053f087E87a25dC60701ba6E663b1a548E85.
Trading will begin later today if liquidity conditions are met. Once sufficient supply of this asset is established trading on our LRDS-USD trading pair will launch in phases. Support for LRDS may be restricted in some supported jurisdictions.
Posted Jul 24, 2024 - 08:54 PDT
Monitoring
Coinbase will add support for BLOCKLORDS (LRDS) on the Ethereum network (ERC-20 token). Do not send this asset over other networks or your funds may be lost. Transfers for this asset are available on @Coinbase & @CoinbaseExch in the regions where trading is supported.