Coinbase Exchange System Issues
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted May 19, 2023 - 09:15 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2023 - 01:35 PDT
Investigating
Coinbase Exchange is currently experiencing issues. While we work on a fix, your funds remain secure.
Posted May 19, 2023 - 01:20 PDT