Our PEPE-USD trading pair is now in full-trading mode on @CoinbaseExch and Advanced Trade. Limit, market and stop orders are all now available.
Posted Nov 13, 2024 - 08:41 PST
Update
Our PEPE-USD trading pair will now enter auction mode. Customers can post limit orders and view the resulting indicative open price. The books will be in auction mode for a minimum of 10 minutes during which no matches will occur. Upon completion of the auction, crossed orders will be matched at the opening price.
Posted Nov 13, 2024 - 08:31 PST
Monitoring
Coinbase will add support for Pepe (PEPE) on the Ethereum network (ERC-20 token). Do not send this asset over other networks or your funds may be lost. Transfers for this asset are available on @Coinbase & @CoinbaseExch in the regions where trading is supported. Trading will begin on or after 11:30AM ET 13 November, 2024 if liquidity conditions are met. Once sufficient supply of this asset is established trading on our PEPE-USD trading pair will launch in phases. Support for PEPE may be restricted in some supported jurisdictions.
The Ethereum network (ERC-20 token) contract address for Pepe (PEPE) is 0x6982508145454ce325ddbe47a25d4ec3d2311933