Update to USD Banking Partners

Incident Report for Coinbase Exchange

Resolved

This incident has been resolved.
Posted Jul 24, 2023 - 20:07 PDT

Update

Coinbase Exchange is sharing an update to non-US clients regarding facilitating USD withdrawals and deposits. Details will be sent to your email on file. Should you have further questions you can reach our Exchange Operations Team at [email protected].
Posted Mar 13, 2023 - 04:26 PDT

Monitoring

Coinbase Exchange has elected to change our banking partners for facilitating USD withdrawals and deposits, effective immediately. Please update your Coinbase payment instructions. Details have been sent to your email on file.

Should you have further questions you can reach our Exchange Operations Team at [email protected].
Posted Mar 02, 2023 - 05:08 PST
This incident affected: Transfers (Coinbase US Bank Accounts, Coinbase US Wires).