Delays in settlement for a few products
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Mar 25, 2022 - 11:26 PDT
Identified
We are experiencing delays in settling matches for a few products. We are actively working to address this issue.
Posted Mar 25, 2022 - 06:48 PDT
This incident affected: Settlement.