Degraded Performance - Transactions
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Dec 11, 2024 - 19:05 PST
Identified
We are aware that some users may experience latency or degraded performance when transacting, our team is investigating and working to resolve.
Posted Nov 25, 2024 - 22:57 PST