Our SWELL-USD trading pair is now in full-trading mode on @CoinbaseExch and Advanced Trade. Limit, market and stop orders are all now available.
Posted Nov 08, 2024 - 11:17 PST
Update
Our SWELL-USD trading pair will now enter limit-only mode on @CoinbaseExch and Advanced Trade. Limit orders can be placed and canceled, and matches may occur. Market orders cannot be submitted.
Posted Nov 07, 2024 - 12:10 PST
Update
Our SWELL-USD trading pair will now enter auction mode. Customers can post limit orders and view the resulting indicative open price. The books will be in auction mode for a minimum of 10 minutes during which no matches will occur. Upon completion of the auction, crossed orders will be matched at the opening price.
Posted Nov 07, 2024 - 11:35 PST
Monitoring
Coinbase will add support for Swell (SWELL) on the Ethereum network (ERC-20 Token). Do not send this asset over other networks or your funds may be lost. Transfers for this asset are available on @Coinbase & @CoinbaseExch in the regions where trading is supported. Trading will begin later today if liquidity conditions are met. Once sufficient supply of this asset is established trading on our SWELL-USD trading pair will launch in phases. Support for SWELL may be restricted in some supported jurisdictions. The Ethereum network (ERC-20 token) contract address for Swell (SWELL) is 0x0a6E7Ba5042B38349e437ec6Db6214AEC7B35676. Coinbase will add support for SWELL with the Experimental label. Learn more about the Experimental label here: https://help.coinbase.com/en/coinbase/trading-and-funding/buying-selling-or-converting-crypto/experimental