Updated USD Deposit Instructions

Incident Report for Coinbase Exchange

Resolved

This incident has been resolved.
Posted Jul 19, 2024 - 15:13 PDT

Monitoring

We are continuing to monitor this incident, all clients should continue to review updated deposit instructions in their Exchange portal.
Posted Jul 19, 2024 - 10:27 PDT

Investigating

As a result of the global outage we have updated our USD deposit instructions in the Coinbase Exchange portal. We advise that all clients review updated instructions to ensure successful transactions.
Posted Jul 19, 2024 - 08:38 PDT