Delayed UK bank deposits
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 17:42 PDT
Investigating
We are aware that some UK bank deposits are delayed. We are investigating this issue and will provide an update shortly. Rest assured, your funds are safe.
Posted Sep 06, 2024 - 15:37 PDT