Euro Coin (EUROC) will be renamed to EURC
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Jun 24, 2024 - 08:39 PDT
Update
Our EURC-EUR trading pair will now enter limit-only mode on @CoinbaseExch and Advanced Trade. Limit orders can be placed and canceled, and matches may occur. Market orders cannot be submitted.
Posted Jun 21, 2024 - 09:28 PDT
Update
Our EURC-USD trading pair will now enter limit-only mode on @CoinbaseExch and Advanced Trade. Limit orders can be placed and canceled, and matches may occur. Market orders cannot be submitted.
Posted Jun 21, 2024 - 09:25 PDT
Update
Our EURC-USD and EURC-EUR trading pairs will now enter auction mode. Customers can post limit orders and view the resulting indicative open price. The books will be in auction mode for a minimum of 10 minutes during which no matches will occur.
Posted Jun 21, 2024 - 09:10 PDT
Update
The renaming of Euro Coin (EUROC) to EURC has been delayed. We apologize for these delays, but rest assured your funds are safe and our teams are working as quickly as possible to restore full service. The EUROC asset ticker has been replaced by EURC across all applicable surfaces on Coinbase.
Posted Jun 20, 2024 - 17:26 PDT
Update
The renaming of Euro Coin (EUROC) to EURC is taking longer than expected. We apologize for these delays, but rest assured your funds are safe and our teams are working as quickly as possible to restore full service.
Posted Jun 19, 2024 - 15:13 PDT
Update
EUROC is being renamed to EURC soon.

📢Beginning today at 8AM PT through June 19 3PM PT users will temporarily be unable to buy, sell, or transfer EUROC on Coinbase Exchange.
Posted Jun 17, 2024 - 08:55 PDT
Monitoring
Starting June 19, 2024, Euro Coin (EUROC) will be renamed to EURC to reflect an update by Circle, the asset issuer. There will be no change to how the asset functions outside of being represented by the new name. Here’s what to expect 👇

Between June 17 8AM PST and June 19 3PM PT users will temporarily be unable to buy, sell, or transfer EUROC on Coinbase Exchange. Starting June 19 at 3PM PT, the EUROC asset ticker will be replaced by EURC across all applicable surfaces on Coinbase Exchange. Your EUROC holdings on Coinbase Exchange will be converted 1-1 to EURC. EURC will use the same contract address as currently used for EUROC.
Posted Jun 17, 2024 - 08:50 PDT
This incident affected: Asset / Book Listings.