Unable to View Payment Methods
Incident Report for Coinbase Exchange
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 01:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2024 - 06:09 PDT
Investigating
We’re aware that some Exchange clients may be experiencing issues with using SEPA and SWIFT payment methods on the UI. We have identified the issue and are working on resolving. Rest assured your funds remain safe.
Posted Oct 21, 2024 - 04:07 PDT